Arcanist HTTP Auth stopped working

Hello,

We always used to have Phabricator secured with HTTP authentication. This always used to include the /api/ URL extension to which Arcanist talked. In our .arcrc, we used to have the following (actual values replaced by …):

{
  "config": {
    "default": "...",
    "http.basicauth.user": "...",
    "http.basicauth.pass": "..."
  }
}

This always used to work, but after upgrading to Phabricator 95662ae8f1a7 and Arcanist f0f95e5b2612, it no longer works. Arcanist now gets a 401 Unauthorized back from the server whenever trying to do anything (like install-certificate, for example), so we had to remove HTTP Auth from the /api/ URL extension.

Reproduction Instructions

  • Secure Phabricator with Basic HTTP Authentication by configuring Apache as such
  • Put your HTTP credentials in ~/.arcrc, as illustrated above
  • Try to connect to Phabricator with Arcanist, by performing any operation, for example install-certificate

Phabricator/Arcanist Version
arcanist f0f95e5b2612d011592f9dbe1885756c5219c70b (22 Mar 2021)

Looks like it was removed earlier this year:

Configuration

  • The http.basicauth.user and http.basicauth.pass configuration options are no longer supported. These served a very niche use case. If you’re a customer and need this, we can provide some similar capability via PhutilHTTPEngineExtension; file a support request.

https://secure.phabricator.com/T13203

I see, thank you!