Cannot import Waterfox repo on Github

I tried to observe the Waterfox repo on Github here https://github.com/MrAlex94/Waterfox.git. But it failed
Initialization Error Pull of 'R47' failed: File system entity '/repos/47/hooks' does not exist.
Other repos on Github observed just fine. This is the only repos it’s having problem. Does anyone know what’s going wrong?

Maybe you’re out of disk space, or maybe that directory was created using wrong system user, and now the daemons can’t write to /read it?

That can’t be it. I deleted and create new repos to osbserve Waterfox and same thing happened. Other new repos work just fine. There was another error that shown before this error but I forgot to copy it. It says something like if I manually delete /repos/47 then the daemon will recreate it correctly. I did that but it still failed.

What version of Phabricator are you running?

What version of Git are you running?

Here is output for my version from Phabricator:
phabricator
ee32c186dd822b90826514ff8fc61740ebc8bd68 (Apr 30 2018)
arcanist
a604548101025875de20a9c263df3790fea425b3 (Apr 27 2018)
phutil
20eff1c8d14f08f05ef72828fa379e871d29662c (Apr 13 2018)
diff
3.3 at /usr/bin/diff
git
2.13.6 at /usr/bin/git
hg
4.5.3 at /usr/bin/hg
pygmentize
2.2.0 at /usr/bin/pygmentize
svn
1.9.7 at /usr/bin/svn

Your version of Phabricator is nearly two years old, so you should first upgrade Phabricator to make sure you aren’t encountering a bug which has already been fixed.

Ok. I will try that. I tried to postpone upgrading fearing new issue can arise but I guess I have to this time.