Config command error

#1

Hi All,

I have pulled the source(git master/origin f13709b13b68a7409d4be72e6c1a0dcd6b81d7db) and run the config command from the linux, and I get the following error:

# ./bin/config
[2019-04-15 03:16:33] EXCEPTION: (Error) Call to undefined function phutil_string_cast() at [<phabricator>/src/infrastructure/env/PhabricatorEnv.php:488]
arcanist(head=master, ref.master=dcd7ef66d0e4), phabricator(head=master, ref.master=f13709b13b68), phutil(head=master, ref.master=1ad42491e44a)
  #0 PhabricatorEnv::getDoclink(string) called at [<phabricator>/src/applications/config/option/PhabricatorClusterConfigOptions.php:34]
  #1 PhabricatorClusterConfigOptions::getOptions() called at [<phabricator>/src/applications/config/option/PhabricatorApplicationConfigOptions.php:133]
  #2 PhabricatorApplicationConfigOptions::loadAllOptions() called at [<phabricator>/src/infrastructure/env/PhabricatorConfigDefaultSource.php:11]
  #3 PhabricatorConfigDefaultSource::__construct() called at [<phabricator>/src/infrastructure/env/PhabricatorEnv.php:183]
  #4 PhabricatorEnv::buildConfigurationSourceStack(boolean) called at [<phabricator>/src/infrastructure/env/PhabricatorEnv.php:95]
  #5 PhabricatorEnv::initializeCommonEnvironment(boolean) called at [<phabricator>/src/infrastructure/env/PhabricatorEnv.php:75]
  #6 PhabricatorEnv::initializeScriptEnvironment(boolean) called at [<phabricator>/scripts/init/lib.php:22]
  #7 init_phabricator_script(array) called at [<phabricator>/scripts/init/init-setup.php:11]
  #8 require_once(string) called at [<phabricator>/scripts/setup/manage_config.php:5]

I have never configured a database as a cluster.
How can I solve the problem?

0 Likes

#2
$ git show 1ad42491e44a
commit 1ad42491e44a1866975b366ae552f1d47761e35b
Date:   Wed Mar 14 10:53:54 2018 -0700

Your lipbhutil/ is more than a year out of date. Update libphutil/ and arcanist/ when you update phabricator/.

0 Likes

#3

I resolved.

Thank you!

0 Likes

closed #4
0 Likes