Diffusion not installed


#1

Hello,

I couldn’t find the application Diffusion in phabricator.

The link for Audit application http://phabricator.mycompany.com/diffusion/commit/ is throwing out a 404 status code.

When I tried to access diffusion.repository.edit using arc in terminal I got the response with {"error":"ERR-CONDUIT-CALL","errorMessage":"ERR-CONDUIT-CALL: Method 'diffusion.repository.edit' belongs to application 'Diffusion', which is not installed.","response":null}

And when I tried to create a diff the response I’m getting is
Unhandled Exception (“Exception”)
Cursor “53” does not identify a valid object in query “PhabricatorProjectQuery”.

Please help me to solve this issue and let me know where I’m doing wrong ?

Thanks


#2

In the home page, in the navbar on the left, click “More Applications” , then “All Applications”, then click “Configure” next to Diffusion, and click “Install” on the menu in the right side.


#3

There is no “Diffusion” option available in “More Application”. I have upgraded the Phabricator and I’m in stable branch.

This is the version details :
phabricator : 37a40d82726b31d45446306b9306b9cd48b219b4 (Sat, Sep 8) (branched from 2a03367a50c0ab2dbeceda0f802bf6e29ae55055 on origin)


#4

click “All Applications” after “more applications”.
You can also use “Advanced Search” to search for the application. Make sure to pick “show all applications” under the “Installed” filter.


#5

Thank’s avivey, I was able to find the application in “Advanced Search”.

When I tried to Install Diffusion, I’m getting an exception as below.
Unhandled Exception ("Exception") Cursor "53" does not identify a valid object in query "PhabricatorProjectQuery".

I have searched out for solving this error, but I failed.
Please help me to figure out this issue.


#6

I’m guessing this has something to do with a custom policy using a project that has been deleted, but I can’t really know more without a full stack trace.

Is this a real install or a demo? Can you just delete everything from the database?


#7

Install is the real one. Deleting from database is not possible since there are running projects in phabricator.

The only exception message I’m getting is the one mentioned above and further information are not available for debugging the issue. Could you please tell where I can produce the full stack trace and solve this issue ?


#8

The error log should be in your webserver’s error log.


#9

Hello avivey, I found that the issue is with my Phabricator account, seems like it got corrupted. The other admins in our team are able to access without getting any exception as mentioned above.