Diffusion won't discover commit

Any troubleshooting tips? Diffusion is observing a Git repo and has the following error:

Commit “[some 40-character hash]” has not been discovered yet! Run discovery before updating refs.

I’ve tried the following from the command line:

./bin/repository update --trace rA gave the error mentioned above.

./bin/repository discover rA said: Discovering “rA”… Done.

But when I tried again to update the repo, I got the same error about the same commit not being discovered.

./bin/repository importing rA said: No importing commits found.

./bin/repository reparse --importing --all rA said: Usage Exception: No commits have been discovered in the “rA” repository!

I restarted the daemons and tried all the same things, and still got the same error about the same commit.

I looked in repository_commit table, and there are no rows with that 40-character hash as their commitIdentifier.

Ideas of what I should try next? If there is no simple fix, is there a straightforward way to tell Diffusion “reimport everything since the dawn of time and parse as appropriate”?