How remove mails from Phabricator mail queue

My google is bouncing mail for noreply@phab.domain.com. After changing this mail id also the mail is still bouncing to noreply@phab.domain.com. Is it the issue of phab or google. If it’s the issue with phab please tell me How to remove this mail queue from phabricator using commands.

Hi Sinoj,

  • Is this self-hosted phabricator?
  • What email server are you running? That’s separate from phabricator.
  • Are you able to send any email from the command line, rather than through phab?

Hi

I am running mail using smtp@gmail.com and configured with cluster mail service inside phab.
And is self hosted in an aws instance.
I doesn’t check with command line .

Ok, right. There’s a variety of ways to configure the mailer. We usually use “Mailer: Sendmail”, in which case if you get email working on the host, it will also work for phab. You might consider trying that option.

You are perhaps using “Mailer: SMTP” instead.

The gmail host is smtp.gmail.com , not smtp@gmail.com. Then, you must set username and password.

In https://secure.phabricator.com/book/phabricator/article/configuring_outbound_email/ , it mentions all the configs to connect to “Mailer: SMTP”. You might try setting those parameters in a different email client (like Thunderbird, Outlook, exim, postfix, any other mailer) as a test to verify they are correct.