Icon seems to not work in subtask definition and custom field

Hi,

Reproduction Instructions
I created Maniphest subtype and try to assign icon but no icon appear on task.

[
  {
    "key": "default",
    "name": "Tache",
    "tag": "Tache",
    "icon": "fa-wrench",
    "color": "blue",
    "children": {
      "subtypes": []
    },
    "mutations": []
  },
  {
    "key": "demande",
    "name": "Demande d'\u00e9volution",
    "tag": "Demande",
    "icon": "fa-thumbs-up",
    "color": "green",
    "children": {
      "subtypes": [
        "default"
      ]
    },
    "mutations": []
  },
  {
    "key": "incident",
    "name": "Incident",
    "tag": "Incident",
    "icon": "fa-bug",
    "color": "red",
    "children": {
      "subtypes": [
        "default"
      ]
    },
    "mutations": []
  },
  {
    "key": "smile",
    "name": "Smile",
    "color": "pink",
    "icon": "fa-smile-o",
    "tag": "Bug de production",
    "children": {
      "subtypes": [
        "default"
      ]
    },
    "mutations": [
      "incident",
      "demande"
    ]
  }
]

image


image

And on my custom field:
image
image

Phabricator/Arcanist Version
image

@Rizzen59 Were you able to figure this out? I’m seeing the same thing when I try to add icons to subtasks following this example.

  {
    "key": "plant",
    "name": "Plant",
    "color": "green",
    "icon": "fa-leaf"
  },

Update: based on this comment, it looks like the icons only appear in typeheads.

I was able to see that in: Maniphest > Edit Query > search in Subtypes

Screen Shot 2021-05-23 at 10.14.08