Is it possible to remove "reply-to" in outbound notification emails?

#1

First off, great application. Your contribution to the world is greatly appreciated. Now for my question…

I am setting up Phabricator using its bitnami stack docker container (link). I managed to get it running and setup a Gmail SMTP for sending emails. I am hosting it in a local computer and for the local intranet; thus I am not using a conventional domain name. My phabricator URI is the of the form http://192.168.42.42. This allows others in the network to access and work with phabricator. Further, Phabricator sends email to new users.

My problem is that Phabricator cannot send notification emails which also have an option for replies. When I use ./bin/mail --show-outbound --id #, I can read the error message, which says “Invalid address: M1+1+HASHVALUE@192.168.42.42”. Since (1) I cannot change my hosting domain and (2) I want to have notifications in this local installation of Phabricator, I feel my only option is to turn of “reply-to” for notification emails.

My question: Can I turn of the ability to “reply-to” option for outbound notification emails?


I will include some basic information for the convenience of anyone looking at this question:

  • phabricator: 51d9453e5341880b79bd40609928ba403e1fe97f (Thu, Apr 4) (branched from 02f94cd7d2885de502d03934af3a0c24453e8e58 on origin)
  • arcanist: 4d22e0f89f10b8a7f47f6ee615e0ccf0f354e582 (Mar 8 2019) (branched from 9830c9316d38988b2dc283ac1a124b73bc8e6c5f on origin)
  • phutil: e9bbfcb1435375919d1d2ac4cb4ce48cff0295cb (Sat, Mar 30) (branched from 524fcf465108216bf2fa6126473873ab8e42360a on origin)
  • php: 7.1.28
  • diff: 3.5 at /usr/bin/diff
  • git: 2.21.0 at /opt/bitnami/git/bin/git

bitnami/phabricator information:

  • bitnami/phabricator: 040ed2d9ea21
    • apache-2.4.39-0
    • php-7.1.28-0
    • mysql-client-10.1.38-0
    • libphp-7.1.28-0
  • bitnami/mariadb: 6d4b937603b3