Minimum PHP versions supported by latest stable Phabricator?

#1 says:

  • PHP: You need PHP 5.2 or newer.

Is it still the cases that PHP 5.2 is the minimum supported PHP version? I’m sure that when I’ve tried to use PHP 7.0 in Stretch that I’ve been told that PHP 7.2 was the minimum…


I’ve been told that PHP 7.2 was the minimum.

What error message did you receive, specifically?


With Ubuntu 16.04’s php 7.0:

This version of Phabricator does not support PHP 7.0. You are running PHP 7.0.32-0ubuntu0.16.04.1. Upgrade to PHP 7.1 or newer.

1 related link(s):

So I guess PHP 5.2-5.6 and PHP >=7.1 are supported?

Also install PHP 7.2 rather than PHP 7.1.



#5 actually doesn’t specify php version, it just installs the “default”, after making sure the default isn’t 7.0. Ubuntu’s “default” just happens to be 7.2 right now.


@epriestley OK that revision removes any shred of confusion.

@avivey Excellent point - I stand corrected!


I guess the only minor follow up is could say:

  • PHP : You need PHP 5.2-5.6, 7.1 or above.

Or something similar to show the range is disjoint?