Missing method setAfterID used in Phame

#1

Observed Behavior:
Phame throws errors on trying to view a post
The problem is visible here:

https://secure.phabricator.com/phame/post/view/773/development_notes_2016_week_24/

>>> UNRECOVERABLE FATAL ERROR <<<
 Call to undefined method PhamePostQuery::setAfterID()
 /core/lib/phabricator/src/applications/phame/controller/post/PhamePostViewController.php:314
 ┻━┻ ︵ ¯\_(ツ)_/¯ ︵ ┻━┻

Expected Behavior:
Phame post should be displayed

Phabricator Version:
phabricator
e51381e2d6fa215d8be94708322316090ed741d2 (Mon, Mar 25) (branched from aae7bdbbdd5646457b6014210e6442ac665fe6e3 on origin)
arcanist
4d22e0f89f10b8a7f47f6ee615e0ccf0f354e582 (Sat, Mar 9) (branched from 9830c9316d38988b2dc283ac1a124b73bc8e6c5f on origin)
phutil
564c7b305974827a6163db4747c168e9fa3c500b (Sun, Mar 17) (branched from 34b68955748bb1b2fcbfa86ad69c0e4856d21906 on origin)
php
7.1.27-1+ubuntu16.04.1+deb.sury.org+1
diff
3.3 at /usr/bin/diff
git
2.21.0 at /usr/bin/git
hg
3.7.3 at /usr/bin/hg
pygmentize
2.1 at /usr/bin/pygmentize
svn
1.9.3 at /usr/bin/svn

Reproduction Steps:
https://secure.phabricator.com/phame/post/view/773/development_notes_2016_week_24/

0 Likes

Undefined method setAfterID() when calling feed.query
#2

Hi,
I can reproduce same error on our setup. It happened after commit - 1b0ef4391032f5b4911ede255839b92e6d602c66
If I rollback to commit prior to that - no issues.

1 Like

#3

We have the same issue, on the latest stable branch commit.
Reverting to a6fd8f04792da6653f987677e7d855e32c964e1c fixes it, as noted above.

0 Likes

#4

Thanks, see https://secure.phabricator.com/D20319.

0 Likes

closed #5
0 Likes