Not able to Open Phabricator UI

Hi Team,

I am trying to configure the phabricator after it is installed successfully on CentOS and following the link https://secure.phabricator.com/book/phabricator/article/configuration_guide/.

However I am not able to login to the UI and it is giving below error. I am sure that the creadentials are valid and I tried with manual login as well and it worked well without any issues. Here is the error when I tried access the UI

Unable to connect to MySQL!
Unable to establish a connection to any database host (while trying "phabricator_config"). All masters and replicas are completely unreachable.
Make sure Phabricator and MySQL are correctly configured.

Also, on CLI, I tried to run the command - ./bin/storage upgrade but it gave me this error.

./bin/storage upgrade
MySQL Credentials Not Configured

Unable to connect to MySQL using the configured credentials. You must
configure standard credentials before you can upgrade storage. Run these
commands to set up credentials:

  phabricator/ $ ./bin/config set mysql.host __host__
  phabricator/ $ ./bin/config set mysql.user __username__
  phabricator/ $ ./bin/config set mysql.pass __password__

These standard credentials are separate from any administrative credentials
provided to this command with __--user__ or __--password__, and must be
configured correctly before you can proceed.

Raw MySQL Error: Attempt to connect to root@127.0.0.1 failed with error
#1251: Client does not support authentication protocol requested by server;

Please note that I could able to login to mysql from cli using the command mysql -u root -p and able to run the query SELECT 1; (Also note that tried with --protocol=TCP and it is also working good)

mysql> SELECT 1;
+---+
| 1 |
+---+
| 1 |
+---+
1 row in set (0.00 sec)

I am not able to find where the issue could be. Could you please help resolving this issue.
Below are the installed components on my VM.

mysql --version
mysql  Ver 8.0.11 for Linux on x86_64 (MySQL Community Server - GPL)
php --version
PHP 5.3.3 (cli) (built: Mar 22 2017 12:27:09) 
Copyright (c) 1997-2010 The PHP Group


uname -a
Linux gtstashtest1b 2.6.32-696.23.1.el6.x86_64 #1 SMP Tue Mar 13 22:44:18 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Googling #1251: Client does not support authentication protocol requested by server; shows “consider upgrading MySQL client” is the rest of the error.

I don’t remember seeing this error, but it’s possible that there’s some incompatibility: Your php is very old (2010) and your mysql is very new (April 2018). Maybe try to either use a more recent php, or a similar mysql version (5.something), and see if things work out?

Yup. I was also suspecting the incompatibility. I am going to try with mysql 5 and see how it goes.

That fixed the issue!! Definitely a compatible issue…