Notifications are marked read immediately without actually reading them


#1

Observed Behavior:
In Chrome notifications are marked as read immediately upon arrival, without the user actually reading them. The notification counter stays at zero and the Unread Notifications page stays empty. This causes users to miss notifications they’ve subscribed to.

The only notification that is not marked read is the test notification.

Expected Behavior:
Notifications should only be marked read after the user has read them, as happens in other browsers (tested Firefox and Safari).

Phabricator Version:
phabricator 8ef2f4086ee3479853f045d0fa1457bebd833bbd (Mon, Dec 3) (branched from 9bfe558587aa55d8f0cf037640e3cfee6d642593 on origin)

arcanist 45a8d22c74a62624e69f5cd6ce901c9ab2658904 (Mon, Nov 12) (branched from 3534d2baca4bf6dcdac46c49164bf5ba3a6660ad on origin)

phutil 2a2d4fce881ea48974e7356ca4cf3d33105998f0 (Mon, Dec 3) (branched from 35d0ec2dfa595fd77410b67032e3e4262d170b6d on origin)

Reproduction Steps:

  1. Navigate to Phabricator in Chrome (version 70).
  2. Request a test notification. Check that the notification counter in the top bar shows 1 unread notification.
  3. Mark the test notification read.
  4. Generate another ‘regular’ notification. Note that the notification counter is not increased.
  5. Go to https://phabricator.example.com/notification/query/unread/. See that the notification is not listed as unread notification.

#2

Check your “Email Preferences” under your user settings. You will only get in-browser notifications (and the associated bell icon indicating unread notifications) for object types that you have marked as “Notify” on that settings page. This seems to be working as expected in both Chrome and Safari.


#3

You’re right! Apparently this used to be different in the past and users got confused about this. Changing the settings to Notify solves it.


#4