Pasting screenshot images from clipboard not working in Chrome but works in Firefox

Summary
Recently pasting the screenshot images from clipboard (CTRL + V) stopped working when using Phabricator in Chrome. However if Firefox was used to access phabricator it is working fine.
Before last 2-3 weeks ago, I accessed phabricator only from chome browser; it was working perfectly fine. Issue started only recently.

This problem happens in the writing area, either in the task description section or the comment section of a task or a revision.

Few things I tried to check
When tried with CTRL + V nothing happens, the text area will keep as blank. Later checking in the chrome inspect, noticed an error in the console.

Error screenshot


Error message displayed in console is,

differential.pkg.js:15 Uncaught TypeError: Cannot read properties of null (reading 'name')
    at result.<anonymous> (differential.pkg.js:15)
    at Function.pass (core.pkg.js:164)
    at Function._dispatchProxy (core.pkg.js:159)
    at Function.dispatch (core.pkg.js:142)
    at HTMLHtmlElement.JX.__rawEventQueue (init.js:19)

I tried to check the error by setting breakpoint in the differential.pkg.js, code part is,

for (var ii = 0; ii < clipboard.items.length; ii++) {
    var item = clipboard.items[ii];
    if (!/^image\//.test(item.type)) {
        continue;
    }
    var spec = item.getAsFile();
    if (!spec.name) {
        spec.name = 'pasted_file';
    }
    this.sendRequest(spec);
}

The item.getAsFile() is returning null. However as it was working in Firefox, I tried to check the value of item.

The value of item is, (chrome cosole debugger)

>>item
DataTransferItem {kind: 'string', type: 'image/bmp'}

Now as it is working in firefox; I tried to break point in firefox as well and checked the item value,
(firefox cosole debugger)

>>item
DataTransferItem { kind: "file", type: "image/png" }

I couldn’t understand this difference in type and kind shown by chrome and firefox.

My understanding about screenshot images on clipboard; they don’t have any extension like png, jpeg etc. They are in the bitmap or bmp format. The application like firefox and chrome may choose how it accesses the image and processing the image.

Another thing is,
For the images in clipboard as they are not saved, they don’t have a name. Firefox is giving a name as image.png when uploaded in phabricator. So I checked the names of the images that I was able to upload when I was using chrome 2-3 weeks ago; they have the name as image.png as well, similar behaviour as firefox is showing.
There is a comment that references the use of image.png in chromium bugs conversation - Ref: comment 16.

My environment
OS: Ubuntu 18.04.5 LTS
GNOME: GNOME Shell 3.28.4
Chrome: Version 93.0.4577.63 (Official Build) (64-bit)
Firefox: 91.0.2 (64-bit)

Also only today I came to know that the Linux has two clipboards, PRIMARY and CLIPBOARD so not sure if the issue only with linux or it is there in Windows as well. Even maybe specific to Ubuntu.
I already confirmed with a friend using Ubuntu 20.04 he seeing same issue as well. Couldn’t confirm on Windows OS.

What is the question?
Well, I really liked the CTRL + V for pasting quick screenshots into phabricator. So since past 2-3 weeks for uploading images into phabricator; I am pasting the image into image editor like pinta, then save the image to a file, and use upload in phabricator. This is not as convinient as just using CTRL + V of course.
Today I somehow found while doing trial-error, it works in Firefox, so I will start using firefox for accessing phabricator from now on.

But still want your help to understand,
What may have caused screenshot image pasting from clipboard to stop working in chrome?

Thinking if it was due to chrome browser update, I tried downgrading chrome to 92.0.4515.107-1 version by downloading the deb file from ubuntu updates repository. I couldn’t download the much older versions 91.x those showed file not found.
But this version 92.0.4515.107-1 was released in 2021-07-20 21:08:06 UTC, that time I was able to do CTRL + V pasting. I think it only broke around August 2nd week, sometime after 2021-08-16.
So issue maybe not on chrome browser side. Not sure.

Thanks