Permissions Error on Mac

Observed Behavior:
After installing and configuring phabricator, I get the following message:

FilesystemException
Failed to create a temporary directory in ‘/var/folders/72/cwsbqgnd5md3ykzbwlqvy05r0000gn/T’.

I am running this on a local server on my Macbook pro running Mac OS X Sierra. I have a subdomain setup and have following all steps from the installation instructions.

Expected Behavior:
I assume it should have configured properly and allowed me to use Phabricator (and/or take me to the next step).

Phabricator Version:
Can’t find out due to error. It was cloned from master.

Reproduction Steps:
Run a clean install on a local xampp server on Mac OS X Sierra.

I have no issues running Phabricator on a Mac. My guess is its something to do with how you installed / configured PHP with XAMPP? I’m not familiar with this software myself.

If you have a full stack trace from your webserver log, it could provide some clues - please post it up. In general, if mis-configuration is something we can detect and warn against, we will.

This is what I’m getting in my error logs:

[Fri Aug 11 01:20:46.875914 2017] [authz_core:error] [pid 38183] [client 127.0.0.1:65430] AH01630: client denied by server configuration: /Applications/xampp/htdocs/Phabricator/phabricator/webroot/index.php
[Fri Aug 11 01:20:47.608234 2017] [authz_core:error] [pid 38184] [client 127.0.0.1:65431] AH01630: client denied by server configuration: /Applications/xampp/htdocs/Phabricator/phabricator/webroot/index.php, referer: http://phabricator.localhost.com/
[Fri Aug 11 01:30:54.638892 2017] [authz_core:error] [pid 38185] [client 127.0.0.1:49515] AH01630: client denied by server configuration: /Applications/xampp/htdocs/Phabricator/phabricator/webroot/index.php

I think this does have something to do with XAMPP installation.

Yeah brief Googling seems to suggest Apache configuration: https://stackoverflow.com/questions/18392741/apache2-ah01630-client-denied-by-server-configuration