Personal timezone setting mismatch (Cleared and more specific cases)


#1

Observed Behavior:
Even I set the personal timezone setting, Phabricator lookup wrong value and it shows the alert like Your browser timezone setting differs from the timezone setting in your profile, click to reconcile..
Proof Image: https://imgur.com/a/klDFuVF

Even more, when you set your Personal timezone setting to Austrailia/Adelaide, you can see the message like Your browser timezone (UTC+9) differs from your profile timezone (UTC+9). You can ignore this conflict or adjust your profile setting to match your client.. (Tested with Asia/Tokyo timezone setting OS)
Proof Image: https://imgur.com/a/RzC3bMn

From these two cases, It seems to be that tzdata-like things may use an odd matching table.

I tested this case with the Phabricator which has an only one user.
I rebooted my phd and OS, but still get the same messages.
Also, I tried this in Firefox, Chrome with all-extensions disabled.

Troubling timezone with UTC+9.

  • Asia/Seoul
  • Austrailia/Adelaide
  • Austrailia/Broken_Hills
  • Austrailia/Darwin

Expected Behavior:

  • Get right value from personal timezone setting
  • Show the message Your browser timezone setting differs from the timezone setting in your profile, click to reconcile. in proper situation/condition.

Phabricator Version:

  • phabricator 4214b56a4f4f378e8defdf0f29d6b9228f356560 (Fri, Jun 29)

  • arcanist 875d018360374cb4b1287309782fcb9a75d4bcbf (Tue, Jul 10)

  • phutil 4206849bb05b60f536a1c78e33adee68dac67aa9 (Jun 8 2018)

  • tzdata: tzdata/xenial-updates,xenial-updates,xenial-security,xenial-security,now 2017c-0ubuntu0.16.04 all [installed]

Reproduction Steps:

  • Set your timezone in Phabricator from https://YOURPHABRICATOR/settings/user/YOURACCOUNT/page/datetime/.
  • Change your OS timezone like Asia/Seoul or specified above.
  • (Restart the browser to apply your new timezone setting for the browser)
  • Refresh the pages in Phabricator.

#2

+1 I’m having the exact same issue with the following version:
phabricator 2ddc770fd881de7a5bbe613de49d1456e8c978ae (Thu, Sep 13)
arcanist 30b7835c37b56ac9ea1de6b2291b3fb71c9e6853 (Thu, Sep 6)
phutil a28f6e5d64f316f7aa46e717387ec9af68ff7459 (Thu, Sep 6)

Edit: Solution: I solved this by selecting the “ignore conflict” option at the top of the timezone dropdown list.


#3

Thanks for the report. Fixed in https://secure.phabricator.com/D19873


#4