Phabricator not seeing PHP config changes

Hey recently I’ve installed Phabricator and I have modified settings in the PHP configuration file (/etc/php/7.2/apache2/php.ini) but Phabricator does not recognize these changes even after a restart of the daemons and apache.

How can I get Phabricator to recognize these changes?!?

Which Apache module are you using to serve PHP? They all have their own config files, the one you modified will be the config file for using libphp7.2.so directly. If you are using php-fpm via the proxy_fcgi module, then you will need to edit /etc/php/7.2/fpm/php.ini.

a2query -m should tell you which modules are being used by Apache. If you have multiple versions of PHP installed, you may also need to check further to verify that it is 7.2 that is being used.

root@vps200264:~# a2query -m
authz_host (enabled by maintainer script)
authn_file (enabled by maintainer script)
access_compat (enabled by maintainer script)
status (enabled by maintainer script)
env (enabled by maintainer script)
deflate (enabled by maintainer script)
authn_core (enabled by maintainer script)
auth_basic (enabled by maintainer script)
setenvif (enabled by maintainer script)
autoindex (enabled by maintainer script)
mpm_prefork (enabled by maintainer script)
negotiation (enabled by maintainer script)
alias (enabled by maintainer script)
php7.2 (enabled by maintainer script)
dir (enabled by maintainer script)
rewrite (enabled by site administrator)
filter (enabled by maintainer script)
authz_user (enabled by maintainer script)
mime (enabled by maintainer script)
authz_core (enabled by maintainer script)

It is using php7.2 lib I believe

Bump