Phabricator /status/ page requires correct Host header - could it not?


#1

I’ve got my phabricator install behind an Application Load Balancer in AWS EC2. I have configured the health check for the load balancer to hit /status/ on port 80, the regular nginx port. If I set phabricator.base-uri to my expected value (phabricator.blahblah.net) this health check stops working as it says the address it’s being sent for a Host doesn’t match any known site. Without that key set, the health check works but I obviously get the setup warning saying “set this value”.

Is it possible to disable the host matching for this controller? Given it performs no other real checks it feels like this path should always be available.