PHP 8 incompatible

When attempting to use Phabricator with PHP8, the install is completely broken, throwing an error about get_magic_quotes_gpc() not being found


Reproduction Instructions
Complete steps which allow someone else who does not have access to your environment to reproduce the bug.
Attempt to install Phabricator on PHP 8.0
Browse to install and see an error

Phabricator/Arcanist Version
Output from Config > Version Information or arc version. not attainable currently but on latest git master

No customers currently use PHP8, so PHP8 support is not a priority.

After the release of PHP7, it took about a year for the first customer to be impacted, so the PHP8 support timeline may be similar.