Redirect loop with migrated Phabricator install

Hi all!

We’ve recently had to migrate from server due to our systemadministrator/ISP being too lazy to respond to our tickets. Reinstall has been performed by following the following links:


I’m not sure what the issue is. Here’s what the NGINX vhost config looks like (I’ve omitted some details for privacy reasons):

server {
  root        /home/resonance-team/phabricator/phabricator/webroot;
  listen 443 ssl;
  location / {
    index index.php;
    rewrite ^/(.*)$ /index.php?__path__=/$1 last;
  }

  location /index.php {
    fastcgi_pass unix:/var/run/php/php7.4-fpm.sock;
    fastcgi_index   index.php;

    #required if PHP was built with --enable-force-cgi-redirect
    #fastcgi_param  REDIRECT_STATUS    200;

    #variables to make the $_SERVER populate in PHP
    fastcgi_param  SCRIPT_FILENAME    $document_root$fastcgi_script_name;
    fastcgi_param  QUERY_STRING       $query_string;
    fastcgi_param  REQUEST_METHOD     $request_method;
    fastcgi_param  CONTENT_TYPE       $content_type;
    fastcgi_param  CONTENT_LENGTH     $content_length;

    fastcgi_param  SCRIPT_NAME        $fastcgi_script_name;

    fastcgi_param  GATEWAY_INTERFACE  CGI/1.1;
    fastcgi_param  SERVER_SOFTWARE    nginx/$nginx_version;

    fastcgi_param  REMOTE_ADDR        $remote_addr;
  }
}

There’s several things that can result in redirect loop - could be in the Nginx or in Phabricator.
Sometimes it happens because the https termination deletes the s from the uri, or because Phabricator’ phabricator.base-uri is set to an address that’s different from the HOST header in the request.
Using cURL -i should give you some more information about what is happening.