Remarkup named web links no longer allow name to be monospace

Remarkup seems to no longer allow for monospace text to be used in the name of a named link.

A named web link like:

[[ | `google` ]]

Used to produce a hyperlink like this (except actually a link):


Now however, only the url ( is rendered as a hyperlink and the rest of the markup is still shown. Thankfully this form seems to be rendered with Remarkup so the bad behaviour is also reproduced here:

[[ | google ]]

I’m not certain which phabricator/etc… version we were running prior to this (it had been a while since I’d updated) but it was stable branch from November or December 2019.

Phabricator/Arcanist Version

Phabricator Version Information

Library Version Date Branchpoint
phabricator ff6f24db2bc0 Wed, Feb 12 2327578adc94
arcanist 729100955129 Thu, Jan 30 21a1828ea06c
phutil 034cf7cc3994 Thu, Jan 30 cc2a3dbf5903

Other Version Information

Binary Version Path
php 7.2.24-0ubuntu0.18.04.3 fpm-fcgi
diff 3.6 /usr/bin/diff
git 2.17.1 /usr/bin/git
hg Not Available
pygmentize 2.2.0 /usr/bin/pygmentize
svn 1.9.7 /usr/bin/svn

This was never an intended behavior (and no other variation has ever worked, e.g. [[ X | **Y** ]] has never produced a bold link), and was changed to fix a security vulnerability:

I may be able to restore the old behavior without restoring the security vulnerability, but it’s difficult given how the parser works.


Clearly not a huge issue, I’d just assumed it was intentional to render it that way. I mostly just liked the way it looked when I added links to branches in our code review system. :slight_smile:

This is breaking a bunch of our markup, for what it’s worth.

I confirmed that none of the following work:

[[ | `foo` ]]

This also seems to have broken many comments, project descriptions, and RFCs in Wikimedia’s Phabricator instance. I’ve encountered at least a dozen in the past two days.

For example, at

1 Like

and no other variation has ever worked, e.g. [[ X | **Y** ]] has never produced a bold link

Right, but you can just write **[[X | Y]]** to get a bold link. However, you cannot do the same thing with backticks (erm… how do I escape the backtick here?), since monospacing seems to also automatically mean raw code, and the link is not interpreted at all, showing the raw URL. Or is there any workaround here?

This was never an intended behavior

Yeah, you have said so 8 years ago in f6ed62afbc34, while fixing its behavior. :wink: