[Resolved] Config not allowing stdin


#1

Greetings,

I’m getting an error when attempting to configure SMTP using these instructions,
https://secure.phabricator.com/book/phabricator/article/configuring_outbound_email/

I’ve tried the following variants:
./bin/config set --stdin < mailers.json
./bin/config set cluster.mailers --stdin < mailers.json

and get the following:
Usage Exception: Argument ‘–stdin’ is unrecognized. Use ‘–’ to indicate the end of flags.

According to https://my-domain/config/version/, I’m using the following version:
phabricator: d2d5a1f2832df70fa9b5114bb8e5e0203c3eb47b (Nov 10 2017)
arcanist: 622862e0479956c98cf0327b5bcb17abada6a0ec (Nov 7 2017)
phutil: 3510bfbc8879ff9739495b32b3386c4bf644937c (Nov 7 2017)
Local Version: Bitnami Phabricator 2017.45-0

Any suggestions?


#2

Nevermind… Bitnami has it’s own configuration documentation and I got it working using their instructions,
https://docs.bitnami.com/aws/apps/phabricator/#how-to-configure-outbound-email-settings