../scripts/sql/manage_storage.php: No such file or directory


#1

I’m installing phabricator use git clone on homestead. After configuring nginx, browser shows unable to connect to mysql.

When I run:
$./bin/storage upgrade --user <username> --password <password>

I get the following error:
./bin/storage: line 1: ../scripts/sql/manage_storage.php: No such file or directory

I change
../scripts/sql/manage_storage.php
to
/home/vagrant/Code/phabricator/phabricator/scripts/sql/manage_storage.php
in phabricator\bin\storage, and I get the same error as the picture above.

It seems work, but it obviously that I can’t rewrite all file. I really want to know why.
Can anyone help me to point out my mistake?


#2

You didn’t install Phabricator correctly, and all the files in bin/ directory got corrupted.

Follow the official installation instructions, and specifically use git clone to get the code directories set up.


#3

I follow the instructions, and use git clone, but still get the same error.


#4

What does git status say in /phabricator? And git log -1?

These files are symlinks. Git knows how to deal with that, but some other tools replace them with text files that name their target instead.


#5


I’m starting to think maybe it’s because I use virtual machine, since the official doc said “unusual environments are not supported”.


#6

VMs are usually fine, as long as they run a normal OS.

Your logs seem fine; I don’t know what you did wrong. ./bin/storage should be a symlink, but it appears to be a normal file in your machine. The only way I know to get to this situation is to work with a filesystem that doesn’t support symlinks (like Windows), and then copy files over non-git protocol.

Try cloning the directory again, and making sure you got symlinks in the right place. If you think the VM is doing something wrong, maybe try an Ubuntu VM, these normally work fine.