Solved: Stranded projects

I read this post on admins not being able to alter projects, and I understand the philosophy of Phab users - that admins are not all-powerful.

However, I’m in a situation where the current permissions model hinders my job as a “janitor”-style admin: a project owner left the company, and I cannot deactivate the project. So the project is stranded in an incorrect open-state and no one, short of editing the database (?), can fix it.

When objects such as projects see all of their owner accounts deactivated, the mantle of responsibility for cleanup should fall to admins, but it currently cannot. Is there a workaround for this?

If you can login to the machine running Phabricator, you’ll find several executables in .../phabricator/bin directory.
One of these is `./bin/policy’:

$ ./bin/policy
NAME
      policy - manage policies

SYNOPSIS
      policy command [options]
          Administrative tool for reviewing and editing policies.


WORKFLOWS

      help [command]
      Show this help, or workflow help for command.

      show D123
      Show policy information about an object.

      unlock --view user object ...
      Unlock one or more objects by changing their view policies, edit
      policies, or owners.


Use help command for a detailed command reference.
Use --show-standard-options to show additional options.

Thanks @avivey! It seemed promising, but unlock --edit seems to have silently failed, and unlock --owner crashes:

EXCEPTION: (Exception) Object owner can not be unlocked: the unlocking engine ("PhabricatorDefaultUnlockEngine") for this object does not implement an owner unlocking mechanism.

Never mind, edit worked! Thank you.