>>> UNRECOVERABLE FATAL ERROR <<< after update

After updating to the latest GIt versions (today) using the official upgrade guide and with no errors during the upgrade procedure I can see the login screen just fine.
As soond as I try to login I get this one:

Actual Results:

UNRECOVERABLE FATAL ERROR <<<

Class PhabricatorAuthPassword contains 2 abstract methods and must therefore be declared abstract or implement the remaining methods (PhabricatorApplicationTransactionInterface::getApplicationTransactionObject, PhabricatorApplicationTransactionInterface::willRenderTimeline)

/var/www/…/src/applications/auth/storage/PhabricatorAuthPassword.php:3

┻━┻ ︵ ¯_(ツ)_/¯ ︵ ┻━┻

Expected Results:

Login should work.

Versions:
arcanist 3cdfe1fff806d2b54a2df631cf90193e518f42b7 (5 Sep 2019)
libphutil 39ed96cd818aae761ec92613a9ba0800824d0ab0 (30 Sep 2019)

PHP Version :

PHP 7.2.19-0ubuntu0.18.04.2 (cli) (built: Aug 12 2019 19:34:28) ( NTS )
Copyright © 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright © 1998-2018 Zend Technologies

with Zend OPcache v7.2.19-0ubuntu0.18.04.2, Copyright © 1999-2018, by Zend Technologies

Webserver: nginx version: nginx/1.14.0 (Ubuntu)

I can’t reproduce this.

The codebase no longer contains the string willRenderTimeline(). This method was removed in https://secure.phabricator.com/D19918 + https://secure.phabricator.com/D19919.

$ git grep -i willRenderTimeline
$

Likewise, getApplicationTransactionObject() was removed in https://secure.phabricator.com/D19920.

I suspect you didn’t completely restart your webserver after updating. See:

https://secure.phabricator.com/book/phabricator/article/restarting/

You are right. Thank you - this issue can be closed.